1. We have moved to a new forum system. All your posts and data should have transferred over. Welcome, to the new Serebii Forums. Details here
    Dismiss Notice
  2. Be sure to join the discussion on our discord at: Discord.gg/serebii
    Dismiss Notice
  3. If you're still waiting for the e-mail, be sure to check your junk/spam e-mail folders
    Dismiss Notice

Anyone here play Simcity 2013?

Discussion in 'Miscellaneous Discussion' started by Ausgirl, Apr 9, 2013.

Thread Status:
Not open for further replies.
  1. Ausgirl

    Ausgirl Well-Known Member

    Hi guys I bourght the new Simcity game on the release date but I've been having a lot of issues trying to get it to play. I've registered the game and tried multiple servers. I suspect it's probably related to the settings but I don't understand half the stuff there and I don't have the slightest clue how to set it properlly. Nevertheless I've mucked around with it a bit, trying to get it to work and now I can't even remember the default settings, lol. Anyway I've written everything down and hopefully someone will be able to point out the cause of the problem. Btw I'm running this on a windows vista, which I understand isn't the best computer around for video games...

    Screen resolution: 1280 x 768, 60Hz
    Full screen: yes
    Lighting: high
    Textures: high
    Shadows: high
    Geometry: low
    Animation detail: high
    Tilt shift: standard
    Anti aliasing: not ticked
    Framerate cap: 30 Fps
    V-sync: yes
    Brightness: high
    Filter: off
     
  2. Kreis

    Kreis Still Dirrty

    Videogame discussion doesn't belong here. Try OVGD, if it follows the rules there.
     
Thread Status:
Not open for further replies.

Share This Page