• Be sure to join the discussion on our discord at: Discord.gg/serebii
  • If you're still waiting for the e-mail, be sure to check your junk/spam e-mail folders

DS help

There seems to be a problem with the L button on my DSi. It works as if it stuck pushed in.(ie,working all the time) but it doesn't seem to be pushed in at all. I do think that some sunblock managed to find its way in there but I can't be too sure.

Pleaseums to help.
 
As I recall, my sister's friend had a DS with this issue. I tried blowing it out, and it worked for a little while.
 

BCVM22

Well-Known Member
I've tried that already, but is there any way to permanently fix the problem?

By your own admission, you have a globby liquid stuck underneath one of the buttons on your DS. Don't take this the wrong way, but what manner of finger-snap solution are you expecting to find?
 

treeco123

Well-Known Member
that happened to me when I dropped my DSi but when I dropped it on a harder surface it fixed it.

the only way to solve it "safely" that I know of is taking it apart and cleaning the button but I don't know if it would work.
 
Everyone can stop worrying now because I mangaged to lift the button up and put hair pin in to fix the problem.


Thanks guys! ^_^
 
Top